ZFS on Gentoo Linux

sozo1976 sozo1976 at gmail.com
Thu Apr 7 18:45:14 EDT 2011


So that is why my dedupe is working fine then... :-)

http://img852.imageshack.us/f/copy1gbezfsdedupewithco.png/

sdg is a Corsair F60 SSD configured as cache that I bought on sale. I
tried it first as log device but it didn't seem to get used...



On Apr 8, 12:29 am, Maurice R Volaski
<maurice.vola... at einstein.yu.edu> wrote:
> Dedup has obscene memory requirements to store the dedup table, which is
> stored in the l2arc. I'm guessing it's working this table from disk since
> you don't have much memory! The way around this is to use SSD disk as ZFS
> cache devices. It uses that instead of the l2arc. I have no idea whether
> you can do this under the Linux versions of ZFS, though.
>
> I tried dedup on Solaris Express 11 on 50TB pool with 160 GB of SSD and it
> ran about 25% the speed without dedup/SSD. I imagine dedup without SSDs
> would have been way slower.
>
> On 4/7/11 5:52 PM, "Nils Bausch" <nils.bau... at googlemail.com> wrote:
>
>
>
>
>
>
>
> >Update:
>
> >I have had a play with more network file transfer i.e. samba, afp and
> >scp, and come to the conclusion that dedup seems to the killer.
> >What did I try to do?
> >Transfer a 10 GiB file onto a network share located on a zfs
> >filesystem.
> >What happend with dedup enabled?
> >It started smoothly, but then stalled - and continued maybe 30-60
> >seconds later but with a much lower speed.
> >Without dedup?
> >Constant writing, no interruption.
>
> >I have a RAID-Z with 4 1.5 TiB drives and 12 GiB of RAM - which should
> >be more than enough for ZFS. I am not running any disk or memory
> >intensive tasks apart from Virtual machines. Also my zpool is running
> >on version 23, which was the latest version of zfs-fuse. Could this
> >have such an impact on performance? or is there a way to make dedup
> >work without stalling?
>
> >Thanks



More information about the zfs-discuss mailing list