[zfs-discuss] post-boot woes. nothing happens.

Christ Schlacta aarcane at aarcane.org
Sun Jul 31 23:06:09 EDT 2011


On 7/31/2011 19:30, Fajar A. Nugraha wrote:
> On Mon, Aug 1, 2011 at 5:58 AM, Christ Schlacta<aarcane at aarcane.org>  wrote:
>> again, a serries of repeats including updates and snapshots
> ... which makes most of the above commands irrelevant for
> troubleshooting purposes
if apt-get update and apt-get upgrade can break the install, something's 
terribly wrong.
>> zpool create rebirth
>> zpool import rebirth rebirth2
>> zpool snapshot -R rebirth2 at sendsnap
>> zpool send -R rebirth2 at sendsnap | zpool import -D rebirth
>>
>> [[Note: rebirth is now NOT ashift=12]]
>>
>> grub-probe / #it works now, yaay!
>> update-initramfs -c -k 2.6.38-8-server #only kernel installed.  differs from
>> the livecd kernel
>> update-grub
>> grub-install /dev/sda #no error reported
> so your pool name is rebirth. Did you add "rpool=rebirth" on your
> /etc/default/grub, re-run update-grub, and make sure the kernel
> command line is present on /boot/grub/grub.cfg?
>
>> properly exit, umount, chroot and export rebirth
>> reboot, grub menu shows, rescue mode loads kernel then init, but nothing
>> happens, kernel clearly starts detecting devices, not sure where it's
>> getting hung up.
>> now.
> One easy way to check is to remove "quiet" and "splash" from
> /etc/default/grub and /boot/grub/grub.cfg, and see what the last few
> lines of output are. You're probably missing something simple like the
> pool name.
>
I've removed quiet and splash from default/grub and no text appears.  
when I use the rescue mode, I see a message indicating that I'm loading 
the linux kernel then another showing that I'm loading initrd, but 
nothing.  As I said before, I get TOO MUCH text when I specify debug.  
I've edited the menu items to manually specify those arguments, but I 
haven't tried forcing them in default/grub.

again for clarity: with debug, I get ALOT of text, nothing I can see 
even remotely looks like an error or warning.  Without debug, I get 
absolutely NO kernel text.  both are when quiet and splash are disabled.

I'm trying to create a vmdk now to put the drive in a virtual machine 
and see if it works, but so far I'm having no luck.



More information about the zfs-discuss mailing list