[zfs-discuss] Problem with modpobe / import

Brian Behlendorf behlendorf1 at llnl.gov
Mon Jun 13 14:29:17 EDT 2011


Hi Marcel,

You should certainly be able to recover the pool using the latest
Solaris Express Live CD as suggested.

However, the ZFS on Linux version should be able to recover your pool
too.  The stacks you posted in the bug simply look like advisory notices
to me and not a serious issue.  As long as your seeing ZFS reading from
the pool during import I would let it run.  If your pool is damaged (as
in your case) ZFS may opt to roll it back to the previous transaction
group.  As part of this it can perform a full scrub of the dataset to
ensure it's good before it is imported.  This can take some time.

Just as an anecdote, last week I recovered a damaged OpenIndiana zpool
using ZFS on Linux.  In this case the OpenIndiana system was unable to
recover the pool due to problems with its mptsas driver under load.  The
mptsas driver under Linux doesn't suffer from the same issue so I was
able to recover the pool there.

-- 
Thanks,
Brian 

On Sun, 2011-06-12 at 19:38 -0700, Fajar A. Nugraha wrote:
> 2011/6/13 Marcel J.F. Knopper <marcel at ckxs.com>:
> > Hello,
> >
> > First of all I want to thank the developers for their work. I really enjoy having ZFS on Linux. I'v been testing the package for some time now (since 6.0rc3).
> > But now I've run into a problem I can't solve myself, I hope you can help.
> >
> > Because of a powerfailure and a bad UPS configuration my system lost power in the middle of a volume destroy. After the power was restored I started the server and it never came out of the "modprobe zfs". So in single user mode I renamed the zpool.cache and rebooted. Now the server started. Obviously without the ZFS pool. I the ran "zpool import" and "zpool import pool-id" to import the pool but zpool never completed (well not before I ran out of patience after several hours). After further investigation I found stack traces in the messages log.
> >
> > So I then got the latest build from git and installed that, rebooted and and tried to import the pool again. And again I got the stack trace messages below. Even after the stack traces I still see disk activity with iostat (mostly reading) and top shows 2 to 4 percent processing from ZFS related processes and zpool in state D.
> > The system is dual core P4 3GHz with 8GB mem and "options zfs zfs_arc_max=3221225472" set. The pool is build on 10 sata disks in RAIDZ2 and has dedup and compression enabled.
> 
> Are the vdevs physical disk/partitions?
> 
> If yes, your best bet is probably download latets solaris express live
> CD. Solaris express contains lots of zfs improvements which has not
> been released as open source by Oracle. Import it there, then export
> it. Hopefully you'll be able to import it using zfsonlinux after that.
> 



More information about the zfs-discuss mailing list