Problems installing ubuntu 11.04 with native ZFS root

mfinifter finifter at cs.berkeley.edu
Wed May 18 21:09:16 EDT 2011


I've been following the instructions provided here (https://github.com/
dajhorn/pkg-zfs/wiki/HOWTO-install-Ubuntu-to-a-Native-ZFS-Root-
Filesystem) to try to do an install of Ubuntu 11.04 on a Lenovo
Thinkpad T410s.  I also tried Ubuntu 10.10 with the same results,
which I'll describe below.

I can get through the instructions but the system won't boot.  Here's
what I see after rebooting:

"""
Command: zpool -R / -N tank
Message: Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as
root.
Error: 1

Manually import the root pool at the command prompt and then exit.
Hint: Try:  zpool import -f -R / -N tank


BusyBox v1.17.1 (Ubuntu 1:1.17.1-10ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

#
"""

Some investigation reveals that the zfs modules are not making it into
the initramfs image.  I tried manually unpacking the initramsfs image,
putting the zfs.ko and zfsinfo.ko modules in there, repacking it, and
putting it back into place.  This didn't work at all; it resulted in a
blank screen with nothing printed on the console.

Any ideas as to what I'm doing wrong here?  I followed the
instructions exactly multiple times, with the same result each time.
Thanks in advance for any suggestions.



More information about the zfs-discuss mailing list