[zfs-discuss] Re: Trouble getting ZFS mounted on reboot

Daniel Smedegaard Buus danielbuus at gmail.com
Tue Oct 25 08:09:27 EDT 2011


On Sat, Oct 15, 2011 at 10:33, Larry Schwerzler <larry at schwerzler.com>wrote:

> one last thing, I thought this was solved, but I still had some
> issues.
>
> Not sure what eventually DID solve it, but what I ended up doing was
> setting the mountpoint and canmount properties for each of my zfs
> shares and it started coming up when I rebooted. I didn't change the
> value they were set to, but just re-set them. They must have got
> corrupted or something. *shrug* I do wonder if there are other
> properties I should be concerned with though.
>
>
I have no idea how you got yours working, but this bug has plagued me ever
since I started testing ZFS on Linux. It fails to mount on reboot on ZoL
created pools, on Solaris created pools and on ZFS-FUSE created pools. The
other two versions automount just fine.

I tried your tips, both /etc/default/zfs and re-setting the pool properties
(which already had the correct values, but with a "SOURCE" value of
"default" - after re-setting them, they switched to "local"). Neither works.
I have to manually `sudo zfs mount -a` to mount my pool.

If this isn't a bug, then can someone shed some light on this?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20111025/e37e51e9/attachment.html>


More information about the zfs-discuss mailing list