[zfs-discuss] Failed to perform Soft Reset when using ZFS?

Fajar A. Nugraha list at fajar.net
Thu Apr 5 01:34:05 EDT 2012


On Thu, Apr 5, 2012 at 9:01 AM, Will Rouesnel <w.rouesnel at gmail.com> wrote:
>
> So I've tried a few different variants of the same setup with a straight linear stripe of disks on ZFS - and the problem I keep encountering is my RocketRaid 2340 produces output like this every 30 seconds or so when copying files:
>>
>> Apr  5 10:31:54 xen kernel: [248694.057398] rr2340:start channel [1,1]
>> Apr  5 10:31:59 xen kernel: [248699.357570] rr2340:channel [1,1]: failed to perform Soft Reset
>> Apr  5 10:32:00 xen kernel: [248700.102822] rr2340:channel [1,1] started successfully

> The weird thing is, if I run dd on the drive and zero fill it, I don't get the same problem.

Try sync writes: dd oflag=sync ...

> Now, I know this particular drive has a few bad sectors, but only when running ZFS do I seem to get these resets - which don't appear to actually cause any write failures or checksum errors.

THROW THEM AWAY! Seriously!

Unless of course:
- your data is worthless, in the sense that you wouldn't mind losing any of it
- your time is worthless, in the sense that you don't mind having
these resets when the drive tries desperately many times to read the
data.

-- 
Fajar



More information about the zfs-discuss mailing list