[zfs-discuss] Re: dkms error

Iulian guletz2002 at gmail.com
Fri Aug 2 14:22:57 EDT 2013


2013/7/24 Jake Grimmett <jake.grimmett at gmail.com>

> I've also just seen this problem on Scientific Linux 6.4.
> I'm also zpool using kernel 2.6.32-358.14.1 though I'm not sure if this is
> the cause.
>
> But... on my machine, DKMS has installed itself into /usr/lib64/dkms
> so while /usr/lib64/dkms/common.postinst does exist, it is not being found
>
> A slightly older Scientific Linux 6.4 server (just a few weeks) is using
> /usr/lib/dkms and has no problems...
>
> A workaround is to make a link before building zfs, i.e.
>
>  ln -s /usr/lib64/dkms/ /usr/lib/dkms
>

Jake, my respects - I have solve my problem with Your suggestion (*ln -s
/usr/lib64/dkms/ /usr/lib/dkms*). And thank You very much! You save me.



>  yum install --enablerepo=sl-addons --enablerepo=epel zfs
>
> zfs now works :)
>
> hope this helps
>
> Jake
>
>
> On Saturday, 20 July 2013 21:47:02 UTC+1, guletz2002 wrote:
>>
>> Hello to all,
>>
>> I have update the kernel(centos 4.0 /2.6.32-358.14.1.el6.x86_64), but I
>> have some errors on dkms. I have use the zfs on this machine with at least
>> 5 different kernel version in the past, but I do not have this errors!
>>
>> I have installed this version:
>>
>>   dkms                             noarch
>> 2.2.0.3-8.el6                                epel
>>
>>
>> Running Transaction
>>   Installing : spl-dkms-0.6.1-2.el6.noarch
>>
>> 1/6
>> Non-fatal POSTIN scriptlet failure in rpm package
>> spl-dkms-0.6.1-2.el6.noarch
>> WARNING: /usr/lib/dkms/common.postinst does not exist.
>> ERROR: DKMS version is too old and spl was not
>> built with legacy DKMS support.
>> You must either rebuild spl with legacy postinst
>> support or upgrade DKMS to a more current version.
>> warning: %post(spl-dkms-0.6.1-2.el6.**noarch) scriptlet failed, exit
>> status 1
>>   Installing : zfs-dkms-0.6.1-2.el6.noarch
>>
>> 2/6
>> Non-fatal POSTIN scriptlet failure in rpm package
>> zfs-dkms-0.6.1-2.el6.noarch
>> WARNING: /usr/lib/dkms/common.postinst does not exist.
>> ERROR: DKMS version is too old and zfs was not
>> built with legacy DKMS support.
>> You must either rebuild zfs with legacy postinst
>> support or upgrade DKMS to a more current version.
>> warning: %post(zfs-dkms-0.6.1-2.el6.**noarch) scriptlet failed, exit
>> status 1
>>
>>
>> Thanks!
>>
>


-- 
Cu stima Iulian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130802/6d34479c/attachment.html>


More information about the zfs-discuss mailing list