[zfs-discuss] compression=lz4 not supported on pool version 26?

Durval Menezes durval.menezes at gmail.com
Wed Aug 7 18:28:50 EDT 2013


Hi Omen,

On Wed, Aug 7, 2013 at 7:26 PM, Omen Wild <omen.wild at gmail.com> wrote:

> Quoting Durval Menezes <durval.menezes at gmail.com> on Wed, Aug 07 19:19:
> >
> > > FEAT DESCRIPTION
> > > -------------------------------------------------------------
> > > async_destroy                         (read-only compatible)
> > >      Destroy filesystems asynchronously.
> > > empty_bpobj                           (read-only compatible)
> > >      Snapshots use less space.
> > > lz4_compress
> > >      LZ4 compression algorithm support.
> > > ----- End quote -----
> > >
> >
> > Interesting. So, no way to use lzjb without features (and therefore
> without version=5000)?
>                                  ????
>

Mea culpa, of course I meant "lz4" and not "lzjb".


>
> I'm pretty sure lzjb was supported from the beginning.


Well, if not from the beginning (pool version 1? ;-)), at least from a
loooong time...


> If you meant
> lz4, then yes, you have to upgrade to a really recent version of ZFS
> (but not from Oracle) to support lz4, and those have all gone to
> version=5000 with feature flags.
>

KK, thanks.

Cheers,
-- 
   Durval.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130807/83220da6/attachment.html>


More information about the zfs-discuss mailing list