[zfs-discuss] Fedora 19 Kernel issue

Gordan Bobic gordan.bobic at gmail.com
Thu Aug 8 20:01:38 EDT 2013


On 08/08/2013 10:02 PM, Tren Blackburn wrote:
>
> On Thu, Aug 8, 2013 at 10:03 AM, <amvpadua at gmail.com
> <mailto:amvpadua at gmail.com>> wrote:
>
>     Hi Guys,
>
>     I've been trying to get ZFS to run on F19 and I haven't had any
>     success yet. Do you know of anything I can do to make this happen?
>
>     Native Repo: - Doesn't exist yet
>     Manually editing Repo location - I tried editing zfs.repo and
>     changing $releasever to 18. Yum works and downloads the files, but
>     they don't properly install.
>     Downloading and building my own:  Almost everything works, but
>     compile fails because of an incompatible kernel version (3.10.4).
>
>
> ZoL 0.6.1 does not support 3.10 yet.
>
>     manually altering .configure durint compile: haven't tried it... i
>     figure it might compile but I don't fully understand the
>     consequences and the risks I'll be taking. Too much data to lose.
>
>     SELinux - tried it both on and off. no change.
>
>     Appreciate any ideas... and if you need specifics i can forward
>     whatever i got.
>
>     Thanks so much!
>
>
> I'd personally just compile a vanilla kernel from kernel.org
> <http://kernel.org>. The 3.8 series is the newest that works with ZoL
> 0.6.1 out of the box.

3.9.9 works, too, but bringing up a pool from zpool.cache causes a 
kernel crash. If you make sure zpool.cache is always deleted before the 
zfs module loads, however, and you zpool import -f, it works fine.

Gordan



More information about the zfs-discuss mailing list