[zfs-discuss] Re: zfs volumes not mounting after boot (zfs-mountall not working)

chris at cptechconsulting.com chris at cptechconsulting.com
Sat Aug 10 17:47:54 EDT 2013


I am having the same issue.  Nothing mounted on boot.  Seems like there is 
big issues with drives not being ready/online when zfs tries to mount.  I 
tried everything suggested so far.

My pool is called peedypool
I have a zfs dataset peedypool/nas

setting ZFS_MOUNT=yes will show /peedypool mounted at boot but not 
/peedypool/nas

then I ran zfs mount -a and I got

root at bigfoot:~# zfs mount -a
filesystem 'peedypool/nas' is already mounted
cannot mount 'peedypool/nas': Resource temporarily unavailable


however it doesn't show as mounted.  Then I did a mountall and then it 
shows as mounted.


chris




On Wednesday, July 10, 2013 3:39:30 AM UTC-4, Max Bakulenko wrote:
>
> Good day!
>
> I have the same problem in Ubuntu 12.04. 
> ZFS_MOUNT='yes' in /etc/default/zfs  help with zfs volumes mounting, but I 
> have some ZVOL which usually seen like symlink in  /dev/zvol/poolname but I 
> don't see them.
>
> Max
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130810/c24d9bbf/attachment.html>


More information about the zfs-discuss mailing list