[zfs-discuss] Ubuntu 12.10 trouble mounting on reboot.

chris at cptechconsulting.com chris at cptechconsulting.com
Sat Aug 10 18:00:40 EDT 2013


Darik,
Thank you for the quick reply.

I just implemented the devicewait script and it worked.  Awesome!

Are you saying I shouldn't use vdev aliases?  (sorry im not a developer so 
I don't understand some of the terms you used)


Chris

On Saturday, August 10, 2013 5:55:00 PM UTC-4, Darik Horn wrote:
>
> On Sat, Aug 10, 2013 at 4:34 PM,  <ch... at cptechconsulting.com<javascript:>> 
> wrote: 
> > Darik, 
> > I am having the same problem.  If I run sudo mountall then my zfs 
> > filesystems are mounted.  I'ved tried all your solutions and none seem 
> to 
> > fix the issue.  I think the issue is I am using vdev aliases for by disk 
> > id's and I don't think they are loaded when the mount attempts.  Is 
> there a 
> > way to run mount all after the system has booted automatically? 
>
> Please attach the log files and extra detail according to the FAQ, and 
> try to reproduce the problem without vdev aliases. 
>
>
> https://github.com/zfsonlinux/pkg-zfs/wiki/Ubuntu-ZFS-mountall-FAQ-and-troubleshooting 
>
> Note that support for the obsolete zdev configuration file was 
> recently removed from zfsonlinux/pkg-zfs for the Saucy beta builds, 
> but a debconf that warns the user about the configuration file change 
> has not yet been added. 
>
>
> > Also, I was looking at the 6.2 closed issues and it appears some work 
> has 
> > been done in this area... is that the case? 
>
> A `devicewait` hint was recently contributed to the FAQ.  Try it if 
> the device names are stable on the affected system. 
>
> -- 
> Darik Horn <daj... at vanadac.com <javascript:>> 
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130810/c3308314/attachment.html>


More information about the zfs-discuss mailing list