[zfs-discuss] Playing around with zfs-on-root (zfs-dracut on opensuse 12.3)

Krutskikh Ivan stein.hak at gmail.com
Tue Sep 3 18:30:45 EDT 2013


Hi,

I've been testing zfs on root file system for some time now and have some 
questions regarding advance usage of zfs features.

1) Bootfs attribute 

My zfs installations boots with root=ZFS=some_pool/some_fs zfs_force=1. 
However, I read here 
https://github.com/zfsonlinux/zfs/blob/master/dracut/README.dracut.markdown. 
that if i don't specify any root= sctring, initramfs would look for 
importable pool and then proceed with zfs dataset defined by bootfs 
parameter. I tried that an got :

ZFS: attempting to detect root from imported zfs pools
ZFS: attempting to import additional pools

ZFS: no bootfs attribute found in importable found in importable ZFS pool

that repeated a lot and dropped me into dracut shell with no zpools 
imported. when I ran zpool import -f my_pool, I could get bootfs attribute 
of my zpool just fine.

What had I done wrong? Setting bootfs attribute is a very convinient way to 
switch between snapshots and datasets

2) ZFS rollback

What is the best practice for rolling back snapshots of root file system? 
When I try to do it on a live system it hangs and refuses to reboot. This 
is understandable, but I really would like to here an alternative to such 
brute approach.

Thanks in advance!

To unsubscribe from this group and stop receiving emails from it, send an email to zfs-discuss+unsubscribe at zfsonlinux.org.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130903/767e6844/attachment.html>


More information about the zfs-discuss mailing list