[zfs-discuss] Re: Moderate write speeds on Ubuntu

bgribble at gmail.com bgribble at gmail.com
Wed Sep 18 15:31:42 EDT 2013


I'm also experiencing slow write behavior on ubuntu 12.04 with ZoL 0.6.2. 
Running an 11x4TB drive raidz3 (ashift=12) connected to 2x M1015 flashed to 
IT mode with less than 6TB used i'm seeing this (xeon e5530, 8GB ram, no 
dedup) :

time dd if=/dev/zero of=zerofile12.tst bs=4k count=4700000
4700000+0 records in
4700000+0 records out
19251200000 bytes (19 GB) copied, 63.74 s, 302 MB/s

real    1m3.742s
user    0m1.124s
sys    0m59.624s

zpool iostat -v
                                                   capacity     
operations    bandwidth
pool                                            alloc   free   read  
write   read  write
----------------------------------------------  -----  -----  -----  -----  
-----  -----
tank                                            6.84T  33.2T    260    285  
25.1M  25.6M
  raidz3                                        6.84T  33.2T    260    285  
25.1M  25.6M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGBXRTJ      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGBXSRJ      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGBXTNJ      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGAD2ZJ      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGBXP2J      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGD006J      -      -    101     85  
2.97M  3.31M
    ata-Hitachi_HDS5C4040ALE630_PL2331LAGD8VTJ      -      -    101     85  
2.97M  3.31M
    ata-HGST_HDS5C4040ALE630_PL2331LAGJ618J         -      -    101     83  
2.97M  3.31M
    ata-HGST_HDS5C4040ALE630_PL2331LAGJ8MWJ         -      -    101     83  
2.97M  3.31M
    ata-HGST_HDS5C4040ALE630_PL2331LAGJAPAJ         -      -    101     83  
2.97M  3.31M
    ata-HGST_HDS5C4040ALE630_PL2331LAGJ2DHJ         -      -    101     83  
2.97M  3.31M
----------------------------------------------  -----  -----  -----  -----  
-----  -----


During the write 1 CPU core is pegged at 100% in htop, i've tested with and 
without lz4 compression enabled the write speed is the same and the core is 
always pegged. I seem to remember having better performance with ZoL 0.6.1 
but i don't have any data to back that up.



On Thursday, September 12, 2013 6:53:57 AM UTC-7, sanma... at gmail.com wrote:
>
> I set up 4 2TB drives,mirrored in pairs, with ZFS. I get good 200+MB read 
> speeds semi-consistently, more than enough for me, but my write speeds are 
> always down in the 40-50 MB area, which if I remember my drive benchmarks 
> correctly, is comparable to just one of the drives running by itself. I 
> understand that because I'm mirroring I won't get as dramatic of an 
> increase as my read speed, but since ZFS is striping across the two mirror 
> pairs, shouldn't I see some increase?
>
> I'm not familiar enough with ZFS' tools yet to perform diagnoses on what 
> may or may not be wrong here. Does anyone have any tips/commands I can try?
>

To unsubscribe from this group and stop receiving emails from it, send an email to zfs-discuss+unsubscribe at zfsonlinux.org.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20130918/3ed98664/attachment.html>


More information about the zfs-discuss mailing list