[zfs-discuss] Fedora 23 not booting fr zfsI'm reporting here,

covici at ccs.covici.com covici at ccs.covici.com
Tue Apr 26 02:16:19 EDT 2016


hmmm, when I was not using zfs, it worked perfectly and the claim is
that a separate /usr is supported, but even when I mounted just the
/usr, the rest of the pool would not mount using zfs, whereas without
zfs, all worked correctly.

I certainly thought a separate /usr was/is supported,  in the case of
gentoo, using genkernel without systemd and I think even dracut without
systemd did such a thing.

Manuel Amador (Rudd-O) <rudd-o at rudd-o.com> wrote:

> On 04/25/2016 03:18 AM, covici at ccs.covici.com wrote:
> > I get sort of similar results using gentoo, it mounts the root file
> > system, but not any others in the pool and I have a separate /usr where
> > systemd lives.
> >
> >
> 
> Now is a good time as any to remind folks that separate /usr is no
> longer supported in most distributions.  I used to maintain a fork of
> the dracut stuff that would specifically mount /usr after /, but that
> was before /usr stopped being supported.  It is not possible under the
> current Dracut approach to detect which dataset would need to be mounted
> at /usr at the time that the systemd generators execute (before pool
> import).
> 
> If you would like that to work, you will need to hack your initial RAM
> disk to add support for your custom /usr such that your /usr is mounted
> prior to pivot_root in the initial RAM disk, and then maintain that hack
> separately.
> 
> Note that, even with the hack, your system might no longer power off
> cleanly as well.
> 
> -- 
>     Rudd-O
>     http://rudd-o.com/
> 
> 

-- 
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici
         covici at ccs.covici.com


More information about the zfs-discuss mailing list