[zfs-discuss] Checksum errors on both sides of a mirrored vdev?

Gregor Kopka (@zfs-discuss) zfs-discuss at kopka.net
Tue Aug 16 15:24:24 EDT 2016


Dan,

a temporary glitch in your mains could have caused both reads (which are
done in parallel since scrub checks all data, so both sides of the
mirror) to be damaged.

Just a theory though.

Gregor


Am 16.08.2016 um 20:33 schrieb Dan Swartzendruber via zfs-discuss:
>
> 6x2 raid10 pool.  Just noticed this:
>
> [root at nas1 ~]# zpool status
>   pool: tank
>  state: ONLINE
> status: One or more devices has experienced an unrecoverable error.  An
>         attempt was made to correct the error.  Applications are
> unaffected.
> action: Determine if the device needs to be replaced, and clear the
> errors
>         using 'zpool clear' or replace the device with 'zpool replace'.
>    see: http://zfsonlinux.org/msg/ZFS-8000-9P
>   scan: scrub in progress since Tue Aug 16 14:13:08 2016
>     244G scanned out of 795G at 313M/s, 0h29m to go
>     38K repaired, 30.75% done
> config:
>
>         NAME                        STATE     READ WRITE CKSUM
>         tank                        ONLINE       0     0     0
>           mirror-0                  ONLINE       0     0     0
>             scsi-35000c500412ef8b3  ONLINE       0     0     0
>             scsi-35000c50056ed546f  ONLINE       0     0     0
>           mirror-1                  ONLINE       0     0     0
>             scsi-35000c50055e99cdf  ONLINE       0     0     0
>             scsi-35000c50057575fe3  ONLINE       0     0     0
>           mirror-2                  ONLINE       0     0     9
>             scsi-35000c500575759fb  ONLINE       0     0     9 
> (repairing)
>             scsi-35000c5005621857b  ONLINE       0     0     9 
> (repairing)
>           mirror-4                  ONLINE       0     0     0
>             scsi-35000c50041ab0c47  ONLINE       0     0     0
>             scsi-35000c500412ee41f  ONLINE       0     0     0
>           mirror-5                  ONLINE       0     0     0
>             scsi-35000c50055e9a7a3  ONLINE       0     0     0
>             scsi-35000c50041bd3e87  ONLINE       0     0     0
>           mirror-6                  ONLINE       0     0     0
>             scsi-35000c500575e15b7  ONLINE       0     0     0
>             scsi-35000c500426c6f73  ONLINE       0     0     0
>         logs
>           scsi-35000a7203009583e    ONLINE       0     0     0
>
> errors: No known data errors
>
> (it is showing 'repairing' since I just started a scrub.)  This is on
> a (quite old) dell poweredge r905.  I made sure that each of the
> mirrored vdevs is split among the two jbod enclosures.  The enclosures
> are connected to an LSI SAS switch with mini-sas cables.  Another
> mini-sas cable goes to the dell HBA in the poweredge.  The server is
> showing no ECC errors (corrected or otherwise.)  The odd thing is that
> both sides of one of the mirrors shows errors.  The fact that no files
> were flagged would seem to indicate metadata, which has two copies,
> and hence, is repairable?  The fact that two disks in two different
> enclosures are showing the identical number of errors would seem to
> indict either the SAS switch, or the HBA in the poweredge, no?  (I
> suppose it could be the cable from the HBA to the switch too...)
>
>
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss




More information about the zfs-discuss mailing list