[zfs-discuss] install zfs on debian jessie fails

Sander Klein roedie at roedie.nl
Sun Dec 25 06:19:15 EST 2016


Hi,

this problem is fixed by 
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847018 . Now we have 
to wait for it to trickle down to backports...

Sander

On 2016-12-25 08:56, Achim Gottinger via zfs-discuss wrote:
> The zfs-dkms kernel build failed here two weeks ago (debian sid) with
> the 4.8 kernel, stepped back to 4.7 and it workend.
> 
> 
> Am 25.12.2016 um 00:56 schrieb Manfred Braun via zfs-discuss:
>> Hi !
>> 
>> Thanks for your response.
>> What you describe, is essentially, what I've done.
>> 
>> Probably, the reason is in the history of this
>> command sequence ...
>> I installed kernel 4.8 from jessie-backports
>> immidiately before ...
>> 
>> Will verify this tomorrow.
>> 
>> Sincerely,
>> Manfred
>> 
>>> -----Original Message-----
>>> From: George Melikov [mailto:mail at gmelikov.ru]
>>> Sent: Saturday, December 24, 2016 10:11 PM
>>> To: zfs-discuss at list.zfsonlinux.org; webman at manfbraun.de
>>> Subject: Re: [zfs-discuss] install zfs on debian jessie fails
>>> 
>>> Hello, Manfred!
>>> 
>>> I installed zfs from jessie-backports just yesterday, everything was 
>>> ok.
>>> 
>>> You can try my commands:
>>> 
>>> 	# echo "deb http://ftp.debian.org/debian jessie-backports main
>>> contrib" >> /etc/apt/sources.list.d/backports.list
>>> 	# apt update
>>> 	# apt install linux-headers-$(uname -r)
>>> 	# apt install -t jessie-backports zfs-dkms
>>> 
>>> ____________________________________
>>> Sincerely,
>>> George Melikov
>>> 
>>> 
>>> 24.12.2016, 22:16, "Manfred Braun via zfs-discuss" <zfs-
>>> discuss at list.zfsonlinux.org>:
>>>> Hello !
>>>> 
>>>> I've had mainboard and a boot disk error while on my work to
>>>> migrate my whole windows environment to debian jessie.
>>>> Shortly I got replacements.
>>>> 
>>>> Yesterday, I tried to re-install zfs from zol - but failed,
>>>> because there is no source (404). Then I recognized, it's on
>>>> jessie backports. Tried to install from backports, but fails
>>>> with a build error:
>>>> log:
>>>>          error = inode_change_ok(ip, ia); //zpk_inode.c:323
>>>>          implicit declaration of function 'inode_change_ok'
>>>> <
>>>> 
>>>> Now, I have no clue about how to continue. I have an urgent
>>>> need for a proper install source - I am staying month without
>>>> my files.
>>>> Any tips would be great !
>>>> 
>>>> Regards,
>>>> Manfred
>>>> 
>>>> _______________________________________________
>>>> zfs-discuss mailing list
>>>> zfs-discuss at list.zfsonlinux.org
>>>> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss
>> 
>> _______________________________________________
>> zfs-discuss mailing list
>> zfs-discuss at list.zfsonlinux.org
>> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss
> 
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss


More information about the zfs-discuss mailing list