[zfs-discuss] debian-jessie on zfs root?

John Gilmore j.arthur.gilmore at gmail.com
Sun Dec 25 14:40:20 EST 2016


Thank you for that script snippet. It helps, definitely one of the
missing links. It still doesn't boot without manual intervention.
Seems it can't figure out what pool/filesystem to mount!!!

I've tried everything I can think of to fix this, even to installing
the ubuntu versions of zfs-initramfs. I've tried:

zfs-initramfs_0.6.5.6-0ubuntu15_all.deb
zfs-initramfs_0.6.5.8-0ubuntu8_all.deb
zfs-initramfs_0.6.5.8-2_all.deb
zfs-initramfs_1.0-ppa1~trusty_amd64.deb

and of course, the standard jessie backports one: 0.6.5.8-1~bpo8+1

I've even tried setting the "bootfs" property on my pool, which is
named the standard "rpool"
It's ignoring the bootfs property of rpool.
It's ignoring the root=ZFS=rpool/ROOT/debian-1 kernel command line parameter.


So what gives? How SHOULD I be specifying which pool to load?


On Wed, Dec 14, 2016 at 7:57 AM, Achim Gottinger via zfs-discuss
<zfs-discuss at list.zfsonlinux.org> wrote:
>
>
> Am 09.12.2016 um 14:18 schrieb Achim Gottinger via zfs-discuss:
>
>
>
> Am 09.12.2016 um 13:34 schrieb Fajar A. Nugraha via zfs-discuss:
>
> On Fri, Dec 9, 2016 at 4:36 PM, Achim Gottinger via zfs-discuss
> <zfs-discuss at list.zfsonlinux.org> wrote:
>>
>> I did setup jessie with zfs root based on that docs a while back. Did the
>> transition to jessie-backports zfs packages afterwards and had to patch grub
>> to make it work.
>> Just updated an different debian sid system with zfs root and the latest
>> grub package now works without patches. I only had to add boot=zfs to the
>> kernel options manually.
>> So for debian jessie beside the zfs and spl packages from jessie-backports
>> you need the latest grub packages from sid and the boot=zfs kernel option.
>>
>
> Hmmm ...
>
> If debian still needs "boot=zfs", then IMHO their zfs-initramfs (and
> probably grub?) is behind ubuntu w.r.t. zfsroot support. On ubuntu 16.04.1,
> update-grub would correctly add "root=ZFS=rpool/ROOT/ubuntu" (or whatever
> dataset you use for root), and zfs-initramfs is able to use it without the
> need of additional kernel boot parameters.
>
> If you feel similar level of integration is desirable on debian as well, try
> contacting debian maintainers asking to add that feature. Or try porting
> ubuntu's source package to debian (often you only need to rebuild it).
>
> --
> Fajar
>
> Tank you for the feedback!
> Debian developers added an required patch from ubuntu
> https://anonscm.debian.org/cgit/pkg-grub/grub.git/tree/debian/patches/zpool_full_device_name.patch
> to grub with the latest release
> http://metadata.ftp-master.debian.org/changelogs/main/g/grub2/grub2_2.02~beta3-3_changelog.
> With this update-grub now adds root=ZFS=rpool/ROOT/debian.
> Without the boot=zfs option however I ended up on an initramfs rescue shell.
> Last zfs package release was in september, grub was modified in november.
> I assume zfs-initramfs also requires an patch from ubuntu to make the
> boot=zfs paramter unneccessary. Meanwhile I modified /etc/grub.d/10_linux to
> add that parameter for zfs root sections.
>
> Achim~
>
> Compared ubuntu's and debian's zfs-initrafmfs and debian lacks an config
> file .
> After adding this to debian the boot=zfs parameter is no longer required. I
> created an debian bugreport, so it should be fixed soon if the maintainers
> accept thta solution.
>
> /usr/share/initramfs-tools/conf.d/zfs
> -----------------
>
> for x in $(cat /proc/cmdline)
> do
> case $x in
> root=ZFS=*)
> BOOT=zfs
> ;;
> esac
> done
>
> -----------------
>
> Achim~
>
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss
>


More information about the zfs-discuss mailing list