[zfs-discuss] zfs import hangs - options please! :)

Fajar A. Nugraha list at fajar.net
Fri Jan 8 03:19:35 EST 2016


On Fri, Jan 8, 2016 at 11:20 AM, Randy Syring via zfs-discuss <
zfs-discuss at list.zfsonlinux.org> wrote:

>
> Problem:
>
>    - When I tried to reboot back into the operating system normally, I
>    would get a kernel panic.  Unfortunately, there was never detailed info but
>    it did seem to happen immediately after the zfs startup sequence.
>       - In hindsight, I'm guessing this has to do with the /etc dataset
>       trying to be mounted by the zfs tools not working because /etc isn't
>       present.
>    - No problem (so I thought), I have a SystemRescueCD with ZFS support
>    which I used to troubleshoot previously, so I booted it up.
>    - After decrypting the LUKS volume, `zpool import` shows the rpool
>    ONLINE
>    - running `zpool import -R /media/zfs rpool` hangs
>       - The first time I tried running this command, I had to use "-f",
>       presumably because the shutdown I did while in single user didn't properly
>       "export" the device.
>       - `iotop` and `top` show no significant activity during this time.
>       - I can CTRL-C out of the zpool import and then `zfs list` shows
>       the mounted volumes.  But, I don't think they are really mounted because
>       there are no files in the directories they are supposed to be mounted at.
>
>

> Thanks in advance for any help or suggestions you can provide.
>
>

Generic suggestions:
- make sure you're using the latest version of zfs available
- I HIGHLY suggest you use another permanent (i.e. not livecd) ubuntu
installation for resouce environment (e.g. ubuntu on usb disk, or on
another partition of your HDD). It can be on ext4, but have zfs installed
(personally I have a USB stick with ubuntu-on-zfs)
- Try "zpool import -N -R /media/zfs rpool" (note -N). If that works, try
mounting each dataset one by one manually
- revert your setup to have /etc back on root dataset

/tmp can actually be on tmpfs, if you have enough RAM. Just limit its size
on fstab.

-- 
Fajar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20160108/ffdc54bd/attachment.html>


More information about the zfs-discuss mailing list