[zfs-discuss] Trying to install ZFS on CentOS 7.2-1511

Randy Syring randy.syring at level12.io
Fri Jan 8 14:01:55 EST 2016


On Ubuntu, not sure if it's the same on CentOS, the zfs build process is 
handled by dkms.  I just had to patch ZFS to get past a bug I ran into 
and it was relatively simple once I started following directions.  For 
Ubuntu, I used:

https://help.ubuntu.com/community/DKMS

and the command I used where something like:

   709  dkms remove zfs/0.6.5.3 --all
   711  cd /usr/src/
   713  cp -a zfs-0.6.5.3/ zfs-0.6.5.3-rsyring
   717  dkms add zfs/0.6.5.3-rsyring
   719  dkms build zfs/0.6.5.3-rsyring  # default kernel
   720  dkms install zfs/0.6.5.3-rsyring  # default kernel
   722  dkms build zfs/0.6.5.3-rsyring -k 3.13.0-57-generic
   723  dkms install zfs/0.6.5.3-rsyring -k 3.13.0-57-generic

You could use similar commands to rebuild & reinstall the zfs modules 
and make sure they getinto the initramfs correctly.


*Randy Syring*
Chief Executive Developer
Direct: 502.276.0459
Office: 812.285.8766
Level 12 <https://www.level12.io/>

On 01/08/2016 01:50 PM, David C. Miller via zfs-discuss wrote:
>> Hi all,
>>
>> I'm trying to play with ZFS on Linux, with no success so far.  I
>> am using a new minimal installation of CentOS 7.2-1511 and performed
>> a "yum update".  I have also set SELinux to disabled and rebooted.
>>
>> Per the instructions on the ZoL site, I ran the following commands
>> as root:
>>
>> # yum install epel-release
>> # yum install http://archive.zfsonlinux.org/epel/zfs-release.el7.noarch.rpm
>> # yum install kernel-devel zfs
>>
>> All of the above commands appeared to complete OK, but when I ran a
>> simple "zpool status" command, the following messages appears:
>> 	The ZFS modules are not loaded.
>> 	Try running '/sbin/modprobe zfs' as root to load them.
>>
>> When I tried that command I get this message:
>> 	modprobe: FATAL: Module zfs not found.
>>
>> uname -r says "3.10.0-327.4.4.el7.x86_64".
>>
>> Does anyone have any ideas as to what's wrong?
>>
>> Hmmm, just before I posted this, the followng occured to me: the latest version
>> of ZoL is 0.6.5.3 and was released on October 13th, 2015.  The version of CentOS
>> I'm using is from November 2015, so after I send this I'll try the same recipe
>> on CentOS 7.1-1503.
>>
>> Thanks for any ideas in the meantime,
>>
>> --
>> Rich Teer, Publisher
>> Vinylphile Magazine
> Just a point of reference. About two weeks ago I built two CentOS 7.2 systems running 3.10.0-327.3.1.el7.x86_64 and ZFS 0.6.5.3-1.el7.centos just fine. I just update one of them to the latest kernel 3.10.0-327.4.4.el7 and all other updates and rebooted. It came up just fine.
>
> David Miller.
>
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20160108/5ff2eb50/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: email-sigs-logo.png
Type: image/png
Size: 2857 bytes
Desc: not available
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20160108/5ff2eb50/attachment.png>


More information about the zfs-discuss mailing list