[zfs-discuss] zfs-discuss] Low read performance on ZFS based on iSCSI disk

Dan Swartzendruber dswartz at druber.com
Wed Jan 13 07:59:09 EST 2016


I export a raid 10 4x2 using scst with zfs built from master from 4 months or so ago.  I swItched from zvol to files on a dataset due to performance that would deteriorate after some days.  Not the same exact symptoms, but clearly something was not right with zvols.  On a kindle right now, so this is vague.  If you would like more data, I can dig some up later?

kaazoo via zfs-discuss <zfs-discuss at list.zfsonlinux.org> wrote:
>For further troubleshooting I exported 6 disks directly via iSCSI and
>configured the following zpool:
>
>  pool: pool1
> state: ONLINE
>  scan: none requested
>config:
>
>	NAME          STATE     READ WRITE CKSUM
>	pool1         ONLINE       0     0     0
>	  mirror-0    ONLINE       0     0     0
>	    mpath132  ONLINE       0     0     0
>	    mpath133  ONLINE       0     0     0
>	  mirror-1    ONLINE       0     0     0
>	    mpath134  ONLINE       0     0     0
>	    mpath135  ONLINE       0     0     0
>	  mirror-2    ONLINE       0     0     0
>	    mpath136  ONLINE       0     0     0
>	    mpath137  ONLINE       0     0     0
>
>
>I get good performance for write/read:
>
>dd if=/dev/zero bs=1M count=102400 of=/pool1/test/testfile && sleep 5 &&
>dd if=/pool1/test/testfile bs=1M of=/dev/null
>102400+0 records in
>102400+0 records out
>107374182400 bytes (107 GB) copied, 205.016 s, 524 MB/s
>102400+0 records in
>102400+0 records out
>107374182400 bytes (107 GB) copied, 199.504 s, 538 MB/s
>
>
>So the problem with low read performance seems to only exist when the
>iSCSI target is based on a zvol and not when raw disks are used.
>
>
>Regards,
>kaazoo
>_______________________________________________
>zfs-discuss mailing list
>zfs-discuss at list.zfsonlinux.org
>http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss


More information about the zfs-discuss mailing list