[zfs-discuss] How can one import a zpool with missing cache device?

hunter morgan automaticgiant at gmail.com
Wed Jan 20 12:52:55 EST 2016


It's slow going. I've compiled a partial list of uberblocks on the old
cache disk - I need to check the on-disk spec to see if there is
anything else in there important that zdb -l doesn't list. I think I
might try and find the newest one from the downed pool and copy it
becuase changing just the guid_sum was insufficient. Alternatively, I
think at least I also need to change the transaction number in the
uberblock to match the rest of the pool and change the label state to
match as well.

On 19 January 2016 at 06:40, hunter morgan <automaticgiant at gmail.com> wrote:
> I'll keep the list posted. I'm currently working an angle like jaggel
> (https://forums.freenas.org/index.php?threads/recover-data-from-a-pool-that-cannot-be-imported.15107/#post-76056).
> I started trying to forge the pool guid before I found his post, but
> now I realized that at least the guid_sum would have to be changed as
> well. I'll try to get it done and see what happens after class today.
> It seems promising.
>
> On 18 January 2016 at 17:14, Nadjmou BOINA <nadjmou.boina at gmail.com> wrote:
>> Hello Morgan,
>>
>> I saw your post about how to import a zpool with a missing device.
>> I'm contacting you because I'm actually facing the same problem with my
>> server.
>>
>> Did you succeed importing your zpool ?
>> I don't want to believe that I have lost 15 years of data ...
>>
>> Your help would be greatly appreciated
>>
>> Regards,
>> Nadjmou


More information about the zfs-discuss mailing list