[zfs-discuss] zfs large pool - many checksum errors, no read or write errors

Gregor Kopka zfs-discuss at kopka.net
Mon May 16 18:03:38 EDT 2016


PS - here's the link that brought me on the right track back then:
https://bugs.pcbsd.org/issues/7371

Gregor

Am 16.05.2016 um 21:54 schrieb Gregor Kopka via zfs-discuss:
>
> Am 16.05.2016 um 11:09 schrieb Francois Stark via zfs-discuss:
>> Once again - I would like to go back to the fact that we get many checksum errors with zero R/W errors.  That would indicate that the LSI HBA, the cabling and hard disks are running fine, and the errors appear while calulating and comparing the checksums.
> I wouldn't discount the controller. I vaguely remember having to deal
> with one of Avago 9207-8i and the firmware I got it with (20.00.00.00
> iirc) was that buggy that I had to change it to have the controller work
> correctly inside a SuperMicro server with a current linux (as of a year
> ago) - there was constantly garbage inside the pool, so I dumped the
> setup and started from scratch after firmware upgrade and all was fine
> suddenly (system setup is hands-free through a script, so I didn't do
> anything different to make it work).
>
> Their website has about the SAS3008 exactly one PDF of marketing fluff
> and that it was.
> Maybe drop in another older (=well tested) controller to test if it
> really isn't the controller?
>
> Gregor
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss



More information about the zfs-discuss mailing list