[zfs-discuss] Ubuntu 16.04 with ZFS root

Tren Blackburn iam at theendoftime.net
Thu May 19 19:05:24 EDT 2016


 
On May 19, 2016 at 3:43:41 PM, Rich Teer via zfs-discuss (zfs-discuss at list.zfsonlinux.org(mailto:zfs-discuss at list.zfsonlinux.org)) wrote:

> Hi all,
>  
> I'm trying to install Ubuntu 16.04 with Root on ZFS, without much
> (well, any!) success. I'm following Richard Laager's instructions
> at https://github.com/zfsonlinux/zfs/wiki/Ubuntu-16.04-Root-on-ZFS
> to install ZFS on an SSD in my old Sun Ultra 20.
>  
> Things *seem* to go OK until I get to the dpkg-reconfigure tzdata
> step. Perl warns about not being able to set locale, but falls
> back to the en_US.UTF-8 locale:
>  
> root at ubuntu:/# dpkg-reconfigure tzdata
> perl: warning: Setting locale failed.
> perl: warning: Please check that your locale settings:
> LANGUAGE = (unset),
> LC_ALL = (unset),
> LC_COLLATE = "C",
> LC_CTYPE = "en_CA.UTF-8",
> LANG = "en_US.UTF-8"
> are supported and installed on your system.
> perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
> locale: Cannot set LC_CTYPE to default locale: No such file or directory
> locale: Cannot set LC_ALL to default locale: No such file or directory
> /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
> /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
>  
> I then select my timezeon OK.
>  
> I get more locale errors in later steps, but I think I fixed them by
> also running a "locale-gen en_CA.UTF-8".
>  
> The "apt-get install --yes ubuntu-minimal" step is essentially a NOP
> (i.e., I'm told that I'm already at the newest version). Installing
> linux-image-generic installs version 4.4.0.22 (not .21 as in the web
> page, but that's OK I think).
>  
> Everything seems to go OK, until I get to set 5.2 (verifying that the
> ZFS modules are installed):
>  
> root at ubuntu:/# grub-probe /
> zfs
> root at ubuntu:/# ls /boot/grub/i386-pc/zfs*
> ls: cannot access '/boot/grub/i386-pc/zfs*': No such file or directory
> root at ubuntu:/# ls /boot/grub
> unicode.pf2
>  
> Can anyone provide me with any pointers as to where I'm going wrong?
> Any help greatfull;y received!

I think the instructions were written with an i386/x86_64 machine in mind, not a Sun Ultra 20. 

Unfortunately I have no experience configuring grub on a Sun Ultra 20. Hopefully someone else
will be able to help further.

Regards,

Tren


More information about the zfs-discuss mailing list