[zfs-discuss] Ubuntu 16.04 with ZFS root

Rich Teer rich at richjen.com
Tue May 24 23:26:16 EDT 2016


On Tue, 24 May 2016, Tren Blackburn via zfs-discuss wrote:

> I looked in Oracle’s documentation for that hardware and you’re
> correct, UEFI mode is NOT supported. BIOS is your way forward.

Can you please say which Oracle doc you looked in?  I ask because
I looked in the docs I have and couldn't find anything concrete,
but it is very possible that I skimmed past the info I needed...

> Good luck!

With many thanks to Tren and Hajo, I have finally got ZFS root to
work on my Ultra 20!

As I suspected (and Tren confirmed), the Ultra 20 doesn't support
booting from UEFI disks, so my attempts to do so were bound to
fail. :-/  Once I switched to using ye olde MBR booting, it worked
although step 5.5 (update-grub) whined about the boot disk:

root at ubuntu:/# update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-22-generic
Found initrd image: /boot/initrd.img-4.4.0-22-generic
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
done

Despite that error, the grub-install step worked OK, and when I rebooted
the machine it came up fine with root on ZFS!

Thanks again to all who helped, and I'm looking forward to when these
shenanigans aren't necessary (hopefully in 16.10's release).  Now I
can upgrade my home server; yay!

-- 
Rich Teer, Publisher
Vinylphile Magazine

www.vinylphilemag.com


More information about the zfs-discuss mailing list