[zfs-discuss] Incremental snapshot cannot be received "cannot restore to XXXXX: destination already exists"

explosive explosive.tom at gmail.com
Sat Dec 9 06:38:43 EST 2017


Hi,

I have a zfs pool (named "marvin") on my home server. I want to send
individual snapshots of various volumes from marvin to a USB external drive
that I have created as a pool ("backup_usb_2tb_1").

I have create snapshots and sent them to the usb drive as so:

zfs snapshot marvin/audio at usb_backup
zfs send marvin/audio at usb_backup | zfs receive -dF backup_usb_2tb_1

which has created the snapshot on the backup pool as
(backup_usb_2tb_1/audio at usb_backup)

I have then renamed the snapshot on my main pool:

zfs rename marvin/audio at usb_backup marvin/audio at usb_backup_old

and tried to send the incremental changes:

zfs send -i marvin/audio at usb_backup_old marvin/audio at usb_backup | zfs
receive -Fd backup_usb_2tb_1

but I get this error message: "cannot restore to
backup_usb_2tb_1/audio at usb_backup: destination already exists"

I have also tried without "-F" on zfs recv but I get the same message.
Any ideas what I am doing wrong?

Thanks,
Tom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20171209/70a848c7/attachment.html>


More information about the zfs-discuss mailing list