[zfs-discuss] ZFS 0.7.4 not mounting on Ubuntu 16.04.3

Alexander I Kulyavtsev aik at fnal.gov
Fri Dec 15 13:43:50 EST 2017


Thanks! This was it.
I managed to read 0.7.4 Release Notes day before it was updated with fix and also missed your earlier email on other thread.
Apparently RHEL and CentOS Release notes were fixed too:
https://github.com/zfsonlinux/zfs/wiki/RHEL-and-CentOS

As the summary after zfs upgrade (=uninstall; install) to 0.7.4  from 0.7.1 on Scientific Linux I did
# systemctl enable zfs-import.target
in addition to
# systemctl enable zfs-mount

At that time zpool existed but was not imported; there was no cache file /etc/zfs/zpool.cache
Reboot.
Now pool is imported and zfs filesystems mounted.

Check state:
# for f in /usr/lib/systemd/system/zfs* ; do systemctl status $(basename $f) | fgrep preset ; done
   Loaded: loaded (/usr/lib/systemd/system/zfs-import-cache.service; enabled; vendor preset: enabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs-import-scan.service; disabled; vendor preset: disabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs-import.target; enabled; vendor preset: enabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs-mount.service; enabled; vendor preset: enabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs-share.service; enabled; vendor preset: enabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs.target; enabled; vendor preset: enabled)
   Loaded: loaded (/usr/lib/systemd/system/zfs-zed.service; enabled; vendor preset: enabled)

Best regards, Alex.

On Dec 15, 2017, at 1:24 AM, Gena Makhomed via zfs-discuss <zfs-discuss at list.zfsonlinux.org<mailto:zfs-discuss at list.zfsonlinux.org>> wrote:

On 15.12.2017 1:52, Alexander I Kulyavtsev via zfs-discuss wrote:

^ I have the same question. Scientific Linux 7.4.

https://github.com/zfsonlinux/zfs/releases/tag/zfs-0.7.4

Important Notices

The new systemd zfs-import.target file was added to the RPM packages but
not automatically enabled at install time. This leads to an incorrect
unit ordering on startup and missing mounted file systems. This issue
can be resolved by running systemctl enable zfs-import.target after
installing the packages. #6953

--
Best regards,
Gena
_______________________________________________
zfs-discuss mailing list
zfs-discuss at list.zfsonlinux.org
http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20171215/bb7784fc/attachment.html>


More information about the zfs-discuss mailing list