[zfs-discuss] ZFS package on Raspbian 9

ray vantassle rayvantassle at gmail.com
Sun Apr 8 17:05:45 EDT 2018


spl-dkms.postinst has problems.

It can't find the latest kernel version, so it defaults to trying to build
for every kernel which has a directory in /lib/modules. And it fails at the
first one that won't build.

There is no "/boot/config-*" file, so it doesn't know what kernel(s) are
installed.

Fix: sudo touch /boot/config-$(uname -r)

It still won't build, though it says:
Building for 4.14.32-v7+
Module build for kernel 4.14.32-v7+ was skipped since the
kernel headers for this kernel does not seem to be installed.

There's got to be another name mismatch somewhere.

I'm off to dinner, maybe you'll get it figured out by the time I get back.

BTW, zfs complains that it may have problems on a 32 bit system.  And with
only 1GB (500MB on a Zero).  Even if we get it to build, it may lock up.

zfs-fuse may be a better version on the RPi.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20180408/9045317d/attachment.html>


More information about the zfs-discuss mailing list