[zfs-discuss] cannot import 'home': I/O error Destroy and re-create the pool from a backup source

Anton Gubar'kov anton.gubarkov at iits.ru
Tue Apr 24 04:38:43 EDT 2018


I tried to experiment with zdb today and I ran (to verify the integrity of
pool's metadata)
home64 ~ # zdb -sc -eG home

Traversing all blocks to verify metadata checksums and verify nothing
leaked ...

loading vdev 0 of 2, metaslab 3 of 130 ...space_map_load(msp->ms_sm,
msp->ms_tree, SM_ALLOC) == 0 (0x5 == 0x0)
ASSERT at zdb.c:3502:zdb_leak_init_ms()Aborted (core dumped)

It ended with a core dump very quickly.
I started zdb -scL -eG home then to skip verification of space maps. It
still runs. I'll post the outcome as soon as it is completed.


On Mon, Apr 23, 2018 at 2:18 PM Anton Gubar'kov <anton.gubarkov at iits.ru>
wrote:

> another note - I did configure cache dev via /dev/disk/by-id path. Current
> config shows (correct) link via /dev
>
> On Mon, Apr 23, 2018 at 2:10 PM Anton Gubar'kov <anton.gubarkov at iits.ru>
> wrote:
>
>> Dear friends
>>
>> May I ask you to start  a separate discussion on zfs recv -f usage?
>>
>> I've upgraded to kernel 4.16.3 and ZFS v0.7.8-r0-gentoo and tried import
>> -FX. The result was
>> cannot import 'home': one or more devices is currently unavailable
>>
>> zpool import -N immediately following the above message:
>> home64 /usr/src/linux # zpool import -N
>>    pool: home
>>      id: 4810743847386909334
>>   state: ONLINE
>>  status: Some supported features are not enabled on the pool.
>>  action: The pool can be imported using its name or numeric identifier,
>> though
>> some features will not be available without an explicit 'zpool upgrade'.
>>  config:
>>
>> home                            ONLINE
>>   raidz2-0                      ONLINE
>>     wwn-0x5000c500a41a0a00      ONLINE
>>     wwn-0x5000c500a41ae340      ONLINE
>>     wwn-0x5000c500a41b4c57      ONLINE
>>     wwn-0x5000c500a41b7572      ONLINE
>>     wwn-0x5000c500a41ba99c      ONLINE
>>     wwn-0x5000c500a41babe8      ONLINE
>> cache
>>   sdg3
>> logs
>>   wwn-0x30000d1700d9d40f-part2  ONLINE
>>
>>
>>
>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20180424/e4657167/attachment.html>


More information about the zfs-discuss mailing list