[zfs-discuss] Urgent, recover data after zpool destroy and zpool create

Yuntao Liu procyontao at gmail.com
Mon Dec 3 23:54:57 EST 2018


Hi Gregor,

I can not remember whether we changed TRIM support setting.

It could be enabled by default.

Best Regards,
Yuntao


On Tue, Dec 4, 2018 at 5:43 AM Gregor Kopka (@zfs-discuss) via zfs-discuss <
zfs-discuss at list.zfsonlinux.org> wrote:

>
>
> Am 03.12.2018 um 17:26 schrieb Yuntao Liu via zfs-discuss:
> > I got some old guid from /var/log/messages. I tried out but non of
> > them worked. I also tried 'zpool import -FX -n' but it takes forever
> > to completed.
> >
> > I do not think I can bring back those data any more. Because when I
> > used 'dd' to randomly extracted some data from mpatha or mpathaa-ae, I
> > found those data are completely empty. Although the other drives seem
> > to be full of data, I think the 'zpool create' (or maybe -FX)
> > completely erased the data from the affected devices.
> Do you use a ZFS implementation that contains TRIM support?
>
> Gregor
>
>
>
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20181204/5775595d/attachment.html>


More information about the zfs-discuss mailing list