[zfs-discuss] Failed to probe /dev/sdX for filesystem type

ubuntu serv.user ubuntu.serv.user at gmail.com
Mon Feb 5 16:43:41 EST 2018


I followed this guide-
Ubuntu 16.04 Root on ZFS
https://github.com/zfsonlinux/zfs/wiki/Ubuntu-16.04-Root-on-ZFS

However, In Section 5.4
When I issued this command:
  update-grub

I received the following output:
  Generating grub configuration file ...
  Found linux image: /boot/vmlinuz-4.4.0-112-generic
  Found initrd image: /boot/initrd.img-4.4.0-112-generic
  Failed to probe /dev/sdb1 for filesystem type
  Failed to probe /dev/sdb3 for filesystem type
  Failed to probe /dev/sdc1 for filesystem type
  Failed to probe /dev/sdd1 for filesystem type
  Failed to probe /dev/sde1 for filesystem type
  Failed to probe /dev/sde3 for filesystem type
  done

Earlier in the process I successfully created a zpool containing 4 disks in
a raidz2 configuration using this command:

zpool create -f -o ashift=12 -O atime=off -O canmount=off -O
compression=lz4 -O normalization=formD -O mountpoint=/ -R /mnt rpool raidz2
/dev/disk/by-id/usb-SAMSUNG_SSD_SM841_2.5__7_0000AB12354C-0:0-part1
/dev/disk/by-id/usb-TOSHIBA_MK8051GSY_0000AB12348F-0:0-part1
/dev/disk/by-id/usb-WDC_WD32_00BPVT-22JJ5T0_0000AB1235DD-0:0-part1
/dev/disk/by-id/usb-WDC_WD32_00LPVX-75V0TT0_0000AB12369D-0:0-part1

I googled the 'Failed to probe for filesystem type' messages, but wasn't
able to find a fix for this specific issue.

How can I resolve?

Without these being resolved I am unable to boot into the newly installed
system (Step 6.5) because there is no selection option in the GRUB menu.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20180205/649c17c7/attachment.html>


More information about the zfs-discuss mailing list