[zfs-discuss] Failed to probe /dev/sdX for filesystem type

ubuntu serv.user ubuntu.serv.user at gmail.com
Mon Feb 5 22:48:47 EST 2018


I didn't try the workaround because there wasn't an issue from executing
the command-
grub-probe /
It came back with-
zfs

The command
zpool status
came back with-

  pool: rpool
 state: ONLINE
  scan: none requested
config:

NAME                                                     STATE     READ
WRITE CKSUM
rpool                                                    ONLINE       0
 0     0
  raidz2-0                                               ONLINE       0
 0     0
    usb-SAMSUNG_SSD_SM841_2.5__7_0000AB12354C-0:0-part1  ONLINE       0
 0     0
    usb-TOSHIBA_MK8051GSY_0000AB12348F-0:0-part1         ONLINE       0
 0     0
    usb-WDC_WD32_00BPVT-22JJ5T0_0000AB1235DD-0:0-part1   ONLINE       0
 0     0
    usb-WDC_WD32_00LPVX-75V0TT0_0000AB12369D-0:0-part1   ONLINE       0
 0     0

errors: No known data errors
--------------------------------------

Any idea what I should try next?


On Mon, Feb 5, 2018 at 3:54 PM, Richard Laager via zfs-discuss <
zfs-discuss at list.zfsonlinux.org> wrote:

> On 02/05/2018 03:43 PM, ubuntu serv.user via zfs-discuss wrote:
> > I followed this guide-
> > Ubuntu 16.04 Root on ZFS
> > https://github.com/zfsonlinux/zfs/wiki/Ubuntu-16.04-Root-on-ZFS
> >
> > However, In Section 5.4
> > When I issued this command:
> >   update-grub
> >
> > I received the following output:
> >   Generating grub configuration file ...
> >   Found linux image: /boot/vmlinuz-4.4.0-112-generic
> >   Found initrd image: /boot/initrd.img-4.4.0-112-generic
> >   Failed to probe /dev/sdb1 for filesystem type
> >   Failed to probe /dev/sdb3 for filesystem type
> >   Failed to probe /dev/sdc1 for filesystem type
> >   Failed to probe /dev/sdd1 for filesystem type
> >   Failed to probe /dev/sde1 for filesystem type
> >   Failed to probe /dev/sde3 for filesystem type
> >   done
> Did you try the work-around listed in 5.1:
> export ZPOOL_VDEV_NAME_PATH=YES
>
> What is the output of `zpool status`?
>
> --
> Richard
>
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss at list.zfsonlinux.org
> http://list.zfsonlinux.org/cgi-bin/mailman/listinfo/zfs-discuss
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20180205/7a1334e7/attachment.html>


More information about the zfs-discuss mailing list