[zfs-discuss] cannot operate on snapshot: "dataset is busy"

D. R. Evans doc.evans at gmail.com
Thu Feb 15 17:51:08 EST 2018

Gionatan Danti wrote on 02/15/2018 02:45 PM:

> Can you post the output of:
> - zpool list
> - zpool status
> - zfs list -t all
> - zfs list -o space
> - ps ax | grep zfs
> If you try to manually execute "zfs rename $FS at 6 $FS at 7", what happens?

I was going through those commands, preparing the output to include in an
e-mail, and (unbelievably) the "zfs rename $FS at 6 $FS at 7" worked without an
error. I must have tried the same command half a dozen times over the course
of the last couple of days as I tried to figure out the problem myself, and it
*always* failed the same way as the script. But not any more.

I did do (another) reboot just before gathering the output of the commands, so
I was working on a clean system -- but that had never improved anything before.

So for now I'm going to assume that the problem is mysteriously (but
troublingly) fixed. I will monitor the daily output from the cron job and will
re-post with details if the problem recurs, or if anything else strange seems
to be happening.

Thank you for your magic touch :-) !!


Web:  http://enginehousebooks.com/drevans

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <http://list.zfsonlinux.org/pipermail/zfs-discuss/attachments/20180215/aacdfbf2/attachment.sig>

More information about the zfs-discuss mailing list